AppKed

Tags 5324

Postico 1.4.3 – A modern PostgreSQL client.

Appked/ Developer Tools/on 2018-11-10 14:44

Postico 1.4.3

Postico provides an easy to use interface, making Postgres more accessible for newcomers and specialists alike. Postico will look familiar to anyone who has used a Mac before. Just connect to a database and begin working with tables and views. Start with the basics and learn about advanced features of PostgreSQL as you go along. Postico is an intuitive app for looking at data. Filter rows, sort them, rearrange columns. You can examine long text or images conveniently in the sidebar. Even related rows from referenced tables are shown. Edit rows directly, or use the sidebar, a great choice for long text. You can even change multiple rows at once. Batch saving (with SQL preview) lets you commit changes to multiple rows in a single transaction. Postico sports a query view inspired by Sequel Pro, the popular MySQL client. But with sophisticated features like multiple query results, Postico goes even beyond its role model.


WHAT’S NEW

Version 1.4.3:

  • Fixed a bug where the DDL generated for views contained double semicolons
  • Report correct line number when an error occurs during CSV Import
  • Fixed a bug where Postico crashed when trying to import a file that you don't have permissions for
  • Added a workaround to make sure MS office file types in bytea fields are correctly identified on macOS 10.14
  • Fixed a bug where the Postico structure editor shows pending SQL changes (empty) after clicking an index attribute
  • Fixed a bug where autocomplete did not work with the latest cockroach version v2.0.5
  • Fixed a crash when an error message was not valid UTF-8
  • Improved error messages when authenticating to the SSH server fails
  • Fixed display bugs on macOS 10.14
  • Fixed a bug where Postico froze when autocomplete was triggered for a database with many tables or schemas
  • Fixed a bug where Postico ran into a memory leak when exporting large tables as CSV
  • Postico now restores the height of the favorites window correctly
  • Improved compatibility with CockroachDB


REQUIREMENTS

OS X 10.10 or later, 64-bit processor


Screenshots