AppKed

Tags 5319

CodeKit 2.8 – Build websites faster and better.

Appked/ Featured/on 2016-05-01 01:54

CodeKit 2.8

CodeKit helps you build websites faster and better.

Features
  • Compile Everything: – Process Less, Sass, Stylus, Jade, Haml, Slim, CoffeeScript, Javascript, and Compass files automatically each time you save. Easily set options for each language.
  • Live Browser Reloads: – Instantly see changes in your browser, with animation and without hitting the refresh button or installing plugins. Great for tweaking layouts!
  • Combine and Minify: – Reduce load times by mashing Javascript and CoffeeScript files together and then minifying with Uglify.js. It’s so easy, you’ll giggle like a schoolgirl. Seriously.
  • Optimize Images: – Losslessly reduce JPEG and PNG file sizes with one click and see the savings. One less thing to do at deployment. (More compression options coming soon!)
  • JSHint and JSLint: – Makes debugging scripts fun and easy. Instantly find that one hanging comma that kills IE, or enforce coding styles and best practices across teams.
  • Team Collaboration: – Sync project settings across teams and computers in an open JSON format. Keep everyone on the same page or easily jumpstart new sites.
  • Easy Frameworks: – Keep just one copy of a file on your drive and easily use it across many projects without worrying about file paths. No more copying files into every new site.
  • It Just Works: – There’s nothing to install or configure. No mucking around the command line. Just run the app and start working. It’s that easy.


WHAT’S NEW

Version 2.8:

New
  • Safari Tech Preview is now an option for the Preview Browser.
TypeScript
  • You may need to change the Output Module type for your TypeScript files from commonJS to system after this update, due to a change in the TypeScript compiler.
Component Updates
  • Libsass --> 3.3.6
  • MultiMarkdown --> 5.2
  • Less --> 2.6.1
  • Stylus --> 0.54.4
  • TypeScript --> 1.8.10
  • Jade --> 1.11.0
  • Uglify.js --> 2.6.2
  • Autoprefixer --> 6.3.6
  • Bourbon --> 4.2.7
  • Bourbon Neat --> 1.7.4


REQUIREMENTS

OS X 10.8 or later, 64-bit processor


Screenshots